purser v2.5.0

This MINOR release of purser introduces basic support for chain definitions through the ethereumjs-common package.

purser-core now has an internal helper for dealing with this: getChainDefinition, which in turn, is being used through the Ledger, Trezor and MetaMask packages.

This basically adds in support for custom chains. It’s still pretty basic, as some chain IDs might fail ethereumjs-commons internal validation, thus the transaction failing to sign.

Thanks again to @JamesLefrere for having to deal with all the ethereumjs-tx changes and updates.

Monorepo:

  • Updated dev dependencies:
    • eslint #260
    • flow-bin #259
  • Bumped version to next MINOR: 2.5.0

purser-core:

  • Added internal getChainDefinition helper #261
  • Added ethereumjs-common as a direct dependency
  • Bumped version to next MINOR: 2.2.0

purser-ledger:

  • Updated dependencies:
    • @ledgerhq/hw-app-eth #262
    • @ledgerhq/hw-transport-u2f #263
  • Added support for custom chain definitions through purser-core #261
  • Bumped version to next MINOR: 1.4.0

purser-metamask:

  • Added support for custom chain definitions through purser-core #261
  • Bumped version to next MINOR: 2.4.0

purser-trezor:

  • Added support for custom chain definitions through purser-core #261
  • Bumped version to next MINOR: 1.4.0

Link to Github release

1 Like