purser v2.4.1

This is a PATCH release to hotfix the change in one of purser's dependencies, which recently changed it’s import signature: https://github.com/ethereumjs/ethereumjs-tx/issues/159

This was an oversight when upgrading this dependency in release v2.3.0, as the unit test didn’t catch due to the fact that we mock all external libraries when testing.

I guess this is making a case for integration tests.

Thanks to @JamesLefrere for this release as the quick turnaround!

Monorepo:

  • Bumped version to next PATCH: 2.4.1

purser-ledger:

  • Fixed the ethereumjs-tx dependency import #253
  • Bumped version to next PATCH: 1.3.1

purser-metamask:

  • Fixed the ethereumjs-tx dependency import #253
  • Bumped version to next PATCH: 2.3.2

purser-trezor:

  • Fixed the ethereumjs-tx dependency import #253
  • Bumped version to next PATCH: 1.3.1

Link to Github release

1 Like