Installation Issues for Colony Starter

colonystarter

#1

Hi,

Been hacking around for a while trying to figure out how to solve this but no luck so far. Just trying to install the ’ Colony Starter’ kit on OSX. I get the following error:

============
colony-starter colony-starter-basic

Verifying yarn is installed…

Creating colony-starter-basic folder…

Preparing to install @colony/colony-starter-basic…

Installing @colony/colony-starter-basic…

yarn install v1.13.0
[1/5] :mag: Validating package.json…
error @colony/colony-starter-basic@1.0.0-beta.9: The engine “node” is incompatible with this module. Expected version “10.12.0”. Got “11.4.0”
error Found incompatible module
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

Aborting installation. Please report an issue.

Failed to execute yarnpkg

============

I have tried running the “yarn global add @colony/colony-starter” with the “* --ignore-engines” but that step is not causing an issue so not surprised that has not helped.

Can you suggest a way to get around this please?


#2

Hey @jester911!

We have a specific node version set in the colonyStarter packages (10.12.0). This is to ensure everyone is using the same node version when installing a colonyStarter package for the first time.

I would recommend using 10.12.0 and installing Node Version Manager so that you can easily switch between node versions when working on multiple projects that require different versions.

The node version you are using (11.4.0) might work as well but you would need to remove or change the following code in the package.json file:

  "engines": {
    "node": "10.12.0"
  },

Let me know if you have any more questions!