Error in colonyStarter - unable to clone dappsys repository

Hey @Darya!

Did you get it working with ssh installed?

Also, would you like to open a PR in colonyToken or shall I?

Hi Rayan!

I`m just trying to install ssh.

ANd what PR means?

Ok, great! Let me know how it goes!

PR is short for “pull request”. We might want to change .gitmodules in colonyToken to use ssh to prevent this from happening in the future but, as mentioned before, installing ssh is a good best practice.

Also, the colonyStarter packages were updated last night so I would recommend removing @colony/colony-starter globally and installing the new @colony/colony-cli package.

Remove @colony/colony-starter globally:

yarn global remove @colony/colony-starter

Add @colony/colony-cli globally:

yarn global add @colony/colony-cli

Install any of the colonyStarter packages:

colony build [package-name]

Ok, I installed it and ran all commands in Run Example. Everything worked but when I ran yarn test I received the following error:

Could you help me please?

Glad to hear you got it working!

Most of the tests are assigned a 5000 ms timeout so it looks like this one took a bit longer. The test was passing on our CI (continuous integration) but you might need to update the timeout to a larger number (ie 10000) if your computer takes a bit longer to process.

For example, you would want to change the 5000 at the bottom of this test to 10000:

  // Test the signSetTaskBrief() action from account[0]
  test('account[0] signSetTaskBrief() works', async () => {
    state.task = await signSetTaskBrief(
      state.colonyClient[0],          // colonyClient,                  // taskId
      specificationHash: 'QmWvM3isCmEY8bsixThuFeUJmE5MN2he1UxaPzMngLZ7Wq',
  }, 5000);

That being said, it looks like the test working for account[0] but not the later test for account[2], so it might resolve itself but running the tests again.

I also noticed that you are using the colony-starter-basic package, which has been updated and renamed colony-example as of last night. You can view the updated package structure at colonyStarter.

Let me know if you have any more questions.

I`ve just tried to run colony build colony-example from this

and received

No worries! I received the same error last night.

You are receiving this error because the @colony/colony-starter package is still globally installed on your computer. You need to remove the old package and then globally install the @colony/colony-cli package so that the colony command is not overlapping with the old package.

Remove @colony/colony-starter globally:

yarn global remove @colony/colony-starter

Add @colony/colony-cli globally:

yarn global add @colony/colony-cli

I also cleaned my yarn cache but removing the old and adding the new should work too. If you feel the need to clean your yarn cache, you can run the following command before globally installing the new package:

yarn cache clean

Any luck? Did that work for you? Let me know.

I followed your recomendations and tried to run yarn global remove @colony/colony-starter and received

After that I tried to run yarn cache clean and then added colony-cli globally,result was the same: Unable to locate @colony/colony-starter-colony-example on npm

Hmmm… for some reason it won’t let you remove the package, which is why you are receiving the same error. I am not sure why but you can manually remove the package.

Find out where global packages are installed:

yarn global dir

Move to that directory and then go into the node_modules folder and delete the @colony folder. Then you can run a fresh install of the @colony/colony-cli package.

Apologies to make you go through all this! Globally installed packages can be a bit tricky sometimes. If you prefer, you can build packages without globally installing them using npx:

npx -p @colony/colony-cli colony build colony-example

It`s ok) Thank you!

I`ve done all steps and as a result of yarn test received “No tests found”.

Which colonyStarter package did you build? Did you run yarn test from within the project directory?

The only package that does not have tests is the colony-cli package itself, so I am not sure why you would be getting “no tests found” if you built one of the “starter” or “example” packages.

yes, I ran it from colony-example.

I’m not able to reproduce a “no tests found” error after running through the instructions in colony-example.

Can you share the error message?

It looks like you are attempting to run yarn test in an empty directory named colony-example. Was there an error when you ran colony build colony-example?

Also, I would recommend building the package somewhere outside the .config/yarn folder where the globally installed packages are located. That might be part of the issue.

My best recommendation would be to try running through the steps in the colony-example instructions again from a location outside the .config/yarn folder and making sure there are no errors in prior steps.

When I built it outside the .config/yarn I couldn`t remove @colony/colony-starter and buildindg didnt work for colony-example.

Once you’ve removed a package from your globally installed packages, you do not need to remove it again and the issue you were having with removing the globally installed package should be resolved.

I would recommend running through the steps in the colony-example instructions again from a working directory.